Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
aslibanget

Junior Member
Registered:
Posts: 3
Reply with quote  #1 

hallo all,,,, i have some problem with my vt75,,,
indicator show different variable ohm between the other mod, with the same atomizer,,,,
example :
i using Serpent mini + Ni80 coil,,, on other mods ( pico, dagger , triade, ) i get 0.31 - 0.33 ohms, but on my VT75 i get 0.41 - 0.47 ohms,,,,
i need help for solving the problem,,,,,,,

thx b4 all

VapingBad

Avatar / Picture

Administrator
Registered:
Posts: 2,449
Reply with quote  #2 
If that is the one where the outer of the 510 unscrews take that off and clean the threads, if that is the one with one or two screws next to the battery cap check they are snug.  It is almost certainly a ground problem just a case of checking, cleaning and tightening connection points.
__________________
• I am not employed by nor do I represent Evolv Inc.  All opinions are my own, they are just opinion not fact and can be wrong •

Latest versions of EScribe: DNA 200/250DNA 75
Common problems
aslibanget

Junior Member
Registered:
Posts: 3
Reply with quote  #3 
Quote:
Originally Posted by VapingBad
If that is the one where the outer of the 510 unscrews take that off and clean the threads, if that is the one with one or two screws next to the battery cap check they are snug.  It is almost certainly a ground problem just a case of checking, cleaning and tightening connection points.


i has cleaning,,, but doesn't fix the problem,,,, T_T
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.