Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Boobaru03

Junior Member
Registered:
Posts: 4
Reply with quote  #1 
Hi all, My first post here and of course I am the one for a difficult question lol
 So my 133 has been trust and true for a few months now and about 2 weeks ago my original Glacier RDA center post insulator finally decided to go out, causing a large amount of e-liquid to leak through my 510 and down onto the board and screen. I have fixed the center pin on the rda but i fear that the liquid is leaked down into the device due to a screen malfunction the past 2 mornings. 
 Does anyone have any insight as exactly how to remove the chip/battery sled?
 Thanks in advance!
Wayneo

Senior Member
Registered:
Posts: 296
Reply with quote  #2 
Go check if there are any disassembly videos on YouTube. 
__________________
My old tired eyes don't look at skewed, moire filled cell phone photos. Printscreen - Sniping tool or [ALT]+[PRT SCN], open MSPaint and paste [CTRL]+[V]
Boobaru03

Junior Member
Registered:
Posts: 4
Reply with quote  #3 
Quote:
Originally Posted by Wayneo
Go check if there are any disassembly videos on YouTube. 

I already did, all of the links that I found were for the DNA200.
Wayneo

Senior Member
Registered:
Posts: 296
Reply with quote  #4 
Not wanting to sound funny, but the Vaporshark DNA133 does have the DNA200 board in it.
__________________
My old tired eyes don't look at skewed, moire filled cell phone photos. Printscreen - Sniping tool or [ALT]+[PRT SCN], open MSPaint and paste [CTRL]+[V]
Boobaru03

Junior Member
Registered:
Posts: 4
Reply with quote  #5 
Quote:
Originally Posted by Wayneo
Not wanting to sound funny, but the Vaporshark DNA133 does have the DNA200 board in it.

 It does, however removal of the sled/chip assembly would have to be different due to the placement of the sled and the way the battery door opens. I had all 3 of the chip cover screws out and the single screw that attaches the top of the sled to the body and was able to wiggle the sled/chip assembly up on the cip side but the left side of the sled just wouldn't budge. I didn't want to break the sled just to remove the sled/chip assembly.
ChunkyButt200

Avatar / Picture

Administrator
Registered:
Posts: 1,516
Reply with quote  #6 
can't say for sure but VS has been known for using double sided tape when holding things together. my VS rDNA 40 has some and it's holds like cement. i would just contact VS customer service. just explain the screen acting up, nothing more. is your device still within the 4 month warranty? either way their CS is top notch and most likely will cover any problems. they have been nothing but helpful when my VS DNA 200 had to be sent in twice.
__________________
1.21 JIGAWATTS............GREAT SCOTT!........WHAT THE HELL IS A JIGAWATT?
• I am not employed by nor do I represent Evolv Inc.  All opinions are my own, they are just opinion not fact and can be wrong •
Latest versions of EScribe: DNA 200 • DNA 75  Common problems
EVOLV HELP DESK - https://helpdesk.evolvapor.com/?a=add
LOST VAPE WARRANTY REPAIR - http://www.lostvaperepaircenter.com
Boobaru03

Junior Member
Registered:
Posts: 4
Reply with quote  #7 
Quote:
Originally Posted by ChunkyButt200
can't say for sure but VS has been known for using double sided tape when holding things together. my VS rDNA 40 has some and it's holds like cement. i would just contact VS customer service. just explain the screen acting up, nothing more. is your device still within the 4 month warranty? either way their CS is top notch and most likely will cover any problems. they have been nothing but helpful when my VS DNA 200 had to be sent in twice.

That's what I thought, Yeah the device was purchased about 2 months ago so i'm pretty sure that I am still within my warranty. I just didn't want to have to send it off and be without it while they were servicing it. It looks like I may have to go that route though. 
ChunkyButt200

Avatar / Picture

Administrator
Registered:
Posts: 1,516
Reply with quote  #8 
Quote:
Originally Posted by Boobaru03

That's what I thought, Yeah the device was purchased about 2 months ago so i'm pretty sure that I am still within my warranty. I just didn't want to have to send it off and be without it while they were servicing it. It looks like I may have to go that route though. 
better to be safe than sorry. no point in breaking the sled or whatever is stuck and giving you a problem getting the device apart and voiding your warranty. from the time you send it in the mail it'll take about 2 weeks, give or take a few days, to receive the device back. that has been my experience. perfect time to show some unused/forgotten mods some love!

__________________
1.21 JIGAWATTS............GREAT SCOTT!........WHAT THE HELL IS A JIGAWATT?
• I am not employed by nor do I represent Evolv Inc.  All opinions are my own, they are just opinion not fact and can be wrong •
Latest versions of EScribe: DNA 200 • DNA 75  Common problems
EVOLV HELP DESK - https://helpdesk.evolvapor.com/?a=add
LOST VAPE WARRANTY REPAIR - http://www.lostvaperepaircenter.com
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.