Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
pmartin

Junior Member
Registered:
Posts: 2
Reply with quote  #1 
I've been using my Therion 75 for a few months now with no issues.  This past week the battery indicator started flashing with over 20 percent charge displayed which I hadn't noticed it ever doing that in the past.  I also thought it was odd as the fresh batteries where not in the mod all that long and should have not been that low.  I've come to realize the outer battery is not discharging.  I've tried several different sets and all have done the same thing.  The inner battery runs down and the outer stays at 4.17v.  Any thoughts on trouble shooting?
ChunkyButt200

Avatar / Picture

Administrator
Registered:
Posts: 1,516
Reply with quote  #2 
this is documented problem with some of the therion 75's. it's most likely a broken connection. one of the links inside either contact compartment that electrically join both cells. you can either take it apart and fix it yourself or contact lost vape's repair center. that link is in my signature. there is a video, so so quality, that details fixing this problem....


__________________
1.21 JIGAWATTS............GREAT SCOTT!........WHAT THE HELL IS A JIGAWATT?
• I am not employed by nor do I represent Evolv Inc.  All opinions are my own, they are just opinion not fact and can be wrong •
Latest versions of EScribe: DNA 200 • DNA 75  Common problems
EVOLV HELP DESK - https://helpdesk.evolvapor.com/?a=add
LOST VAPE WARRANTY REPAIR - http://www.lostvaperepaircenter.com
pmartin

Junior Member
Registered:
Posts: 2
Reply with quote  #3 
Thank You Chunky!
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.