Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 3 of 3      Prev   1   2   3
giz_60

Avatar / Picture

Senior Member
Registered:
Posts: 796
Reply with quote  #31 
Quote:
Originally Posted by etz1204

 now display is back. and sometimes if i get puff, its not lighting again. haha my mod is weird



That does sound like the fire button is pinching the ribbon while firing...here is the response another user recently received from Evolv about his screen issue:


Date:
 2017-03-08 12:23:01
Name:Nick Coutris
  

Message:

That issue will require a replacement screen to correct.

It is caused by neglecting to tuck the screen ribbon cable away from the fire button when the device is manufactured. This causes the fire button to contact the screen cable every time the button is pressed causing the behavior you are now seeing and eventual failure.

Unfortunately this is not something we would warranty, however we do have replacement screens available here on our website.

Thanks,
Nick Coutris
Evolv, Inc


etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #32 
Quote:
Originally Posted by giz_60
In Escribe, click on Help>About Escribe...then click on the Evolv logo 7 times...then restart device monitor


still tabs are missing haha
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #33 
This may help you on the warranty procedure from Lost Vape.... might discuss this with your vendor also....

http://lostvape.mysimplestore.com/p/warranty



__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

Wayneo

Senior Member
Registered:
Posts: 296
Reply with quote  #34 
Not remotely relevant, but that phantom 3rd cell 'display' was fixed a few updates back in Escribe.
__________________
My old tired eyes don't look at skewed, moire filled cell phone photos. Printscreen - Sniping tool or [ALT]+[PRT SCN], open MSPaint and paste [CTRL]+[V]
etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #35 
Quote:
Originally Posted by giz_60



That does sound like the fire button is pinching the ribbon while firing...here is the response another user recently received from Evolv about his screen issue:


Date:
 2017-03-08 12:23:01
Name:Nick Coutris
  

Message:

That issue will require a replacement screen to correct.

It is caused by neglecting to tuck the screen ribbon cable away from the fire button when the device is manufactured. This causes the fire button to contact the screen cable every time the button is pressed causing the behavior you are now seeing and eventual failure.

Unfortunately this is not something we would warranty, however we do have replacement screens available here on our website.

Thanks,
Nick Coutris
Evolv, Inc




which means i will send them back my mod?
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #36 
My last post gave you Lost Vape's procedure including what the vendor can do, and should do, for you... [thumb]
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

Wayneo

Senior Member
Registered:
Posts: 296
Reply with quote  #37 
".... not something we would warranty, however we do have replacement screens available here on our website." For purchase
__________________
My old tired eyes don't look at skewed, moire filled cell phone photos. Printscreen - Sniping tool or [ALT]+[PRT SCN], open MSPaint and paste [CTRL]+[V]
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.