Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 1 of 3      1   2   3   Next
etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #1 
Hello guys. My mod seems to have problem. As i read some topic here, some of the have same problem as mine. Im having no display on screen and it doesnt even fires. Last night it still firing but no display. Now totally no display and not firing. Ive connected to escribe and its working on there. Hope you can help me out. 

-Therion owner from Philippines Screenshot_1.png 

giz_60

Avatar / Picture

Senior Member
Registered:
Posts: 796
Reply with quote  #2 
It is showing '3' cells on your Device Monitor & the Therion only uses 2...on the 'Mod' tab, make sure it set for 2 cells


Capture1.PNG 

etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #3 
oh yes. some on facebook notice it and teach me how to change it. now its 2 cell. again its firing but the display didnt came back.
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #4 
hum.... what does device monitor show when you try to fire it ? What are the Battery Settings in the Mod Tab?
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

giz_60

Avatar / Picture

Senior Member
Registered:
Posts: 796
Reply with quote  #5 
You may have it in 'Stealth Mode'...
etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #6 
Screenshot_4.png its on normal mode sir. Some says it could be the ribbon. but idk how to fix the ribbon
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #7 
If the ribbon gets pinched by the fire button then the display will need to be replaced.... is the device still in warranty by the mod maker?
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #8 
Quote:
Originally Posted by retird
hum.... what does device monitor show when you try to fire it ? What are the Battery Settings in the Mod Tab?



Here is the screenshot when im firing it. I've notice the Buttons on the right corner is not responding. Screenshot_5.png 

etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #9 
Quote:
Originally Posted by retird
If the ribbon gets pinched by the fire button then the display will need to be replaced.... is the device still in warranty by the mod maker?



maybe still in warranty. just owned this for just 2-3 weeks now.
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #10 
Contact the vendor you got it from.... tell them what it is doing.... they should help you on this if its a pinched ribbon....let us know.....
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #11 
i will try to tell him the problem. but is it okay to still use it? i mean i will use escribe to read ohms , wattage?
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #12 
Yep it should be OK to use it if the display going dark is the only issue....
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

etz1204

Junior Member
Registered:
Posts: 15
Reply with quote  #13 
Thank guys. Feedbacks when the seller will reply
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #14 
[thumb]
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #15 
If the ribbon got pinched by the fire button it is the mod maker who didn't properly position the ribbon cable.  The vendor should help you or give you information on contacting the mod maker... this should be the place to start... if that fails then post back here....
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.