Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Loxias

Junior Member
Registered:
Posts: 10
Reply with quote  #1 
Hi!

My one-month-old mod (SMY SDNA 75) started this morning to behave abnormally all of a sudden.

Pressing the fire button,
either it will stacks on the first screen or it will shows up a mesh from first and second welcome screen.
Needs to press the fire button for about 3 seconds to move on to the normal screen. But then, pressing the fire button, either the screen it will remain unchanged (like frozen), or  changes the indications to whatever it wants!

In the escribe and in the "Atomizer Analyzer" it works normally, showing the correct atomizer's resistor characteristics. Also it seems to work normally in the "Device Monitor" check page.
Generally it vapes as it should does. But the screen is not showing the correct information.

Needless to say that the mod didn't suffer any mistreatment.  
Also tried three different atomizers and three batteries.

Has anybody met such a condition to any DNA 75 mod?

Thank you,
Vassilis

P.S.
I opened a ticket to EVOLV including two screenshots from the Device Monitor page.
Loxias

Junior Member
Registered:
Posts: 10
Reply with quote  #2 
Hi!
Just received a reply from EVOLV to my ticket.

QUOTE
Date:
 2017-03-08 12:23:01
Name:Nick Coutris
  

Message:

Hi Vassilis,

That issue will require a replacement screen to correct.

It is caused by neglecting to tuck the screen ribbon cable away from the fire button when the device is manufactured. This causes the fire button to contact the screen cable every time the button is pressed causing the behavior you are now seeing and eventual failure.

Unfortunately this is not something we would warranty, however we do have replacement screens available here on our website.

Thanks,
Nick Coutris
Evolv, Inc

UNQUOTE

I thanked EVOLV for their quick response because this, if nothing else, shows respect to customers.

giz_60

Avatar / Picture

Senior Member
Registered:
Posts: 796
Reply with quote  #3 
You need to contact the vendor you bought it from...SMY warranties devices to dealers for 6 months...
MacVap

Junior Member
Registered:
Posts: 13
Reply with quote  #4 
So all SMY SDNA 75 devices have this problem?



dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #5 
Quote:
Originally Posted by MacVap
So all SMY SDNA 75 devices have this problem?



I've been inside just two of them and it wasn't a problem.

__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
Loxias

Junior Member
Registered:
Posts: 10
Reply with quote  #6 
Just an update (a bit delayed!)

After contacting the vendor Gearbest, where I bought the mod, and exchanging 4-5 messages, they finally proposed two solutions.
Either I send back the mod (at my expenses of course) and they should refund the money, or keep the mod and they add to my "wallet" the amount of 15 USD.
I choose the second option.

In the meantime, EVOLV decided to send me a new screen as a courtesy!
Very impressive! I, once again, thanked EVOLV not only for their professionalism but for their kindness too. 

Needles to say that after replacing the damaged screen, the mod functions perfectly.

retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #7 
[thumb]
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.