Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Andybenton

Junior Member
Registered:
Posts: 3
Reply with quote  #1 
I mounted my screen with double faced foam backed tape, when I got the screen installed into the mod I noticed it was slightly off center, I removed the screen and in the process the locking tab that closes to latch the ribbon in place came off as well.

Now that we have what happened out of the way, time to talk symptoms. I can hold the screen connector in place and get it to display properly. I can't tell if it needs back pressure or down pressure. I also can't tell if there is a bad spot in the ribbon cable.

I'm wondering if it's best at this point to attempt to RMA the board or if they could even help me. Any and all advice is appreciated, I'm just hoping I didn't buy an other 80 dollar board because I messed up a tiny connector being an idiot!
dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #2 
I certainly can't imagine any problem with an RMA but you have to ask them.
http://helpdesk.evolvapor.com/index.php?a=add

__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
Andybenton

Junior Member
Registered:
Posts: 3
Reply with quote  #3 
i contacted evolv last night about the RMA, well see if its a cost effective option. i cant imagine it would cost any more than the 80 bucks for a new board.
ChunkyButt200

Avatar / Picture

Administrator
Registered:
Posts: 1,516
Reply with quote  #4 
@Andybenton i suspect you'll be pleasantly surprised by their response. just don't expect a super fast response. give it a few days.
__________________
1.21 JIGAWATTS............GREAT SCOTT!........WHAT THE HELL IS A JIGAWATT?
• I am not employed by nor do I represent Evolv Inc.  All opinions are my own, they are just opinion not fact and can be wrong •
Latest versions of EScribe: DNA 200 • DNA 75  Common problems
EVOLV HELP DESK - https://helpdesk.evolvapor.com/?a=add
LOST VAPE WARRANTY REPAIR - http://www.lostvaperepaircenter.com
Andybenton

Junior Member
Registered:
Posts: 3
Reply with quote  #5 
ive got nothing on my hands but time!
im waiting on the battery anyways. thinking i may see if i can add a battery into the cost of the rma. since i need a couple anyways and im looking to test a few out till i find the one im happy with.

 
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.