Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
turnman34

Junior Member
Registered:
Posts: 5
Reply with quote  #1 
my first build. i have a dna250. i have not assembled anything yet. i am awaiting delivery of my battery. i suspect the display i received may be bad. can i check it without battery connected? just plug in usb? i attached photo of new screen. appears there is an issue with crystal. dna250.JPG
dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #2 
The DNA 250 requires battery power to power the screen, it will not light up with USB power alone.
__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
turnman34

Junior Member
Registered:
Posts: 5
Reply with quote  #3 
thanks for reply, that's what i thought.
black lace

Avatar / Picture

Senior Member
Registered:
Posts: 861
Reply with quote  #4 
Issue with crystal?? Have you peeled off the protective film and found a crack in the screen?
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #5 
Has the film of the organic compound (black part of the crystal screen) changed shape since you posted the picture 9 hours ago?  Can you post a more close up picture and picture of your board?
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

turnman34

Junior Member
Registered:
Posts: 5
Reply with quote  #6 
Quote:
Originally Posted by black lace
Issue with crystal?? Have you peeled off the protective film and found a crack in the screen?


no crack. i just thought it would be solid black. i'll get my battery today and verify if it is goood or not. thanks for reply.
turnman34

Junior Member
Registered:
Posts: 5
Reply with quote  #7 
Quote:
Originally Posted by retird
Has the film of the organic compound (black part of the crystal screen) changed shape since you posted the picture 9 hours ago?  Can you post a more close up picture and picture of your board?


no change in shape since i received screen. i will get picture later, as i am not home at this moment. thanks for reply
Wayneo

Senior Member
Registered:
Posts: 296
Reply with quote  #8 
Quote:
Originally Posted by black lace
..... Have you peeled off the protective film .....?
Sheesh, still unanswered, and you should remember if you did this.  [wink]

__________________
My old tired eyes don't look at skewed, moire filled cell phone photos. Printscreen - Sniping tool or [ALT]+[PRT SCN], open MSPaint and paste [CTRL]+[V]
turnman34

Junior Member
Registered:
Posts: 5
Reply with quote  #9 
Quote:
Originally Posted by Wayneo
Sheesh, still unanswered, and you should remember if you did this.  [wink]


yes
black lace

Avatar / Picture

Senior Member
Registered:
Posts: 861
Reply with quote  #10 
Theym all like that looking through it, i thought you were pointing at a crack, once you peal off the protectiv film and look at the screen surface the pixel display area aprox 7mm x 21mm has a slight matt purpul sheen to it and is off center. Good to help centre it up to a slot when fitting. They are tough little beggers and it looks fine..
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.