Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
biggest

Junior Member
Registered:
Posts: 1
Reply with quote  #1 

Hi
I live in Pennsylvania, can you recommend any repair centers that can check some issues that I am having with my Lavabox DNA200?
Specifically, the unit if not used for a few minutes shuts down or goes "to sleep" and will only power on if I plug it in to a power source then unplug it right away, once i plug it in then immediately unplug the unit it will function properly until it sits idle for a few minutes, once left idle it will again not function until plugged in, the battery is charged. I originally though the issue was a faulty battery, however, I bough the extended 1300MAh battery and the problem still exist.
I did open the case and all looks fine, no moisture or e_liquid, I also plugged it into evolve SW and performed a factory reset. An online search indicated a blown inline fuse (onboard 25 amp SMT)
Any suggestions as to the ease of replacing this fuse if that is the problem?

 

Randy

ChunkyButt200

Avatar / Picture

Administrator
Registered:
Posts: 1,516
Reply with quote  #2 
Quote:
Originally Posted by biggest

Hi
I live in Pennsylvania, can you recommend any repair centers that can check some issues that I am having with my Lavabox DNA200?
Specifically, the unit if not used for a few minutes shuts down or goes "to sleep" and will only power on if I plug it in to a power source then unplug it right away, once i plug it in then immediately unplug the unit it will function properly until it sits idle for a few minutes, once left idle it will again not function until plugged in, the battery is charged. I originally though the issue was a faulty battery, however, I bough the extended 1300MAh battery and the problem still exist.
I did open the case and all looks fine, no moisture or e_liquid, I also plugged it into evolve SW and performed a factory reset. An online search indicated a blown inline fuse (onboard 25 amp SMT)
Any suggestions as to the ease of replacing this fuse if that is the problem?

 

Randy

it's the board. That problem cannot be fixed on your own. I live in PA as well. I would open a help ticket with Evolv and ask about an RMA for the board. Link is in my signature.

__________________
1.21 JIGAWATTS............GREAT SCOTT!........WHAT THE HELL IS A JIGAWATT?
• I am not employed by nor do I represent Evolv Inc.  All opinions are my own, they are just opinion not fact and can be wrong •
Latest versions of EScribe: DNA 200 • DNA 75  Common problems
EVOLV HELP DESK - https://helpdesk.evolvapor.com/?a=add
LOST VAPE WARRANTY REPAIR - http://www.lostvaperepaircenter.com
Wigz

Junior Member
Registered:
Posts: 3
Reply with quote  #3 
I had exactly the same problem and opened a ticket with Evolv, sent them the board with the RMA ticket and they replaced it with a new board.
They have great customer support so well worth contacting them.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.