Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
XanderII

Junior Member
Registered:
Posts: 5
Reply with quote  #1 
Hi Guys,

Got my Hcigar VT75 last week. But I do not satisfy the way it vapes. I have a .23ohm build.
I set the wattage in 65 watts, but its going down to 37 watts while puffing.
My battery (LG LG 18650 HG2) is fully charge.

I cannot get enough clouds. Its so annoying. It's a expensive device but im very dissapointed.
The mod is too hot after 8~10 puffs.

If anyone uses VT75, please guide me on how it performs well.
Please help!

Best Regards.
dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #2 
What is the material that the coil is made from?
Where on the mod get hot?

__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
XanderII

Junior Member
Registered:
Posts: 5
Reply with quote  #3 
+dwcraig1

The coil is Kanthal A1. build in Ijoy Combo
The Mod get hot almost all sides.
dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #4 
Clean the threads on the battery cap and it's corresponding threads, I suspect your problem is there. Also if using EScribe Device monitor you can see if you have a really big voltage drop on the battery (because of a bad connection, ect.)
__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
XanderII

Junior Member
Registered:
Posts: 5
Reply with quote  #5 
+dwcraig1

Thank you for the info.
But my unit is new and clean. Arrived last week but I used it yesterday.
If there is a voltage drop. How can I fix it?

Thank you for the response
dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #6 
https://evolvapor.forumchitchat.com/post/hcigar-vt75-overheat-8245163?pid=1293871740
https://evolvapor.forumchitchat.com/post/show_single_post?pid=1293339644&postcount=10&forum=522111
Have a look at this.

__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
XanderII

Junior Member
Registered:
Posts: 5
Reply with quote  #7 
+dwcraig1
thank you for the info. I will try that option.
By the way I have "weak battery" warning.
Is there any specific batteries that I need to use.
I only used LG Choco 18650 HG2. I don't have 26650 yet.

dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #8 
That battery if authentic should be fine. Set your cell soft cut off to 2.7 volts. A bad connection from the battery will result with that warning as well as a low battery. Clean the threads anyway even if they look clean.
__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
XanderII

Junior Member
Registered:
Posts: 5
Reply with quote  #9 
+dwcraig1
Thank you I'll done cleaning it. And the result is the same.
When I remove the battery, its almost blistering.
Maybe it's the battery is the problem. How do I check the battery if it is legit or not?
Can you suggest me a couple of battery brands?

Thanks
Best Regards.


dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #10 
LG HD2 or LG HD2C or Sony VTC5A
It's certainly possible that it is the battery
[8yFqTuP] 

__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.