Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Doyle4

Member
Registered:
Posts: 59
Reply with quote  #1 

Hey Group.

Got the DNA250 board, Like all boards i receive i hook them via USB to check bits. All DNA200's screens light up when connected VIA usb and no battery, but my DNA250, the screen comes on but no backlight, is this a faulty screen? Thanks.

ChunkyButt200

Avatar / Picture

Administrator
Registered:
Posts: 1,516
Reply with quote  #2 
no backlight? oled's don't have a back light like lcd's do. post a pic. i'm curious as to what the screen looks like. i do know someone else in this forum said his dna 250 would not turn with just the usb inserted. he needed to have the battery connected for it to function.
__________________
1.21 JIGAWATTS............GREAT SCOTT!........WHAT THE HELL IS A JIGAWATT?
• I am not employed by nor do I represent Evolv Inc.  All opinions are my own, they are just opinion not fact and can be wrong •
Latest versions of EScribe: DNA 200 • DNA 75  Common problems
EVOLV HELP DESK - https://helpdesk.evolvapor.com/?a=add
LOST VAPE WARRANTY REPAIR - http://www.lostvaperepaircenter.com
Nick

Avatar / Picture

Evolv
Registered:
Posts: 147
Reply with quote  #3 
The 250 does not turn the screen on with USB power, hook a battery up and it should be good to go.
Doyle4

Member
Registered:
Posts: 59
Reply with quote  #4 

Ah thats a shame.

Thanks for the heads up though. Do you know if they will implement this in a later firmware?

Doyle4

Member
Registered:
Posts: 59
Reply with quote  #5 

@ChunkyButt200
From what i can see, the screen just stays black, as if its dead. Not a fan of this feature i must admit, heart stopped for awhile haha.

 

James

Avatar / Picture

Administrator
Registered:
Posts: 304
Reply with quote  #6 
This is part of the reverse battery protection. It won't pull any power from the port unless it sees a reasonable positive battery voltage.
Doyle4

Member
Registered:
Posts: 59
Reply with quote  #7 
Thanks guys, 
Installed the 250board into a VTbox for now to make sure shes all working whilst i put her through tests. All working great so far.
One feature id like to see is, to be able to save a DNA200 board settings, wire presets etc etc and be able to import them across to the DNA250, iv tried but get a message saying a DNA250 is plugged in and not a DNA200.
mikepetro

Senior Member
Registered:
Posts: 189
Reply with quote  #8 
It might be good to make a footnote about this in the Datasheet. Several people have had similar panic moments expecting the screen to light up like the DNA200 did.
Doyle4

Member
Registered:
Posts: 59
Reply with quote  #9 
^^ +1 - Agreed 
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.