Evolv DNA Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
eliviardo

Junior Member
Registered:
Posts: 6
Reply with quote  #1 
Hi, I'm new here and I hope you can help me.
Been a fan of DNA chips ever since, and every dna chip mod i've used I charge via the usb port and everything worked perfectly 'til now. I bought a new device, Finder dna250w. I've had it for about a month and everything ran smoothly until all of a sudden it won't charge my batts anymore. Whenever i plug it to my usb cable the screen turns on(indicating it detects the cable I assume?) but it doesn't charge, also i can connect to escribe, and i've mingled with it following every tutorial in the internet but still didn't fix my charging problem. Also i can still use the device smoothly it's just that it doesn't charge my batts anymore, also my batts are good because I still use them only now i charge them via the external chargers. I'm always on the go and don't have time to charge my batts externaly. Someone please help. Thanks!
dwcraig1

Avatar / Picture

Administrator
Registered:
Posts: 1,248
Reply with quote  #2 
See this thread:
https://evolvapor.forumchitchat.com/post/new-hcigar-dna-250-wont-charge-batteries-8449956?pid=1295140046

__________________
I am not connected with and do not represent Evolv Inc. All opinions are my own. They are just opinions and may not be correct.
eliviardo

Junior Member
Registered:
Posts: 6
Reply with quote  #3 
Thanks, yes, I've tried every adapter/cable i have every one of them works on my phone and other devices, the thing is that i can still use the device smoothly with no issues and can still connect it to escribe, and i've already asked thinkvape and evolv about this issue, but they still haven't replied yet. 
giz_60

Avatar / Picture

Senior Member
Registered:
Posts: 796
Reply with quote  #4 
You might want to try & contact the vendor who you actually bought the device from as well....most vendors have at least a 30 day warranty period....
retird

Avatar / Picture

Administrator
Registered:
Posts: 1,187
Reply with quote  #5 
Do other devices charge properly using usb of the computer?
__________________
I am not an employee of and do not represent Evolv Inc.  My opinions are just that and are not meant to be fact or even correct.

Wayneo

Senior Member
Registered:
Posts: 296
Reply with quote  #6 
And maybe check that USB charging has not been disabled on the device. 
__________________
My old tired eyes don't look at skewed, moire filled cell phone photos. Printscreen - Sniping tool or [ALT]+[PRT SCN], open MSPaint and paste [CTRL]+[V]
giz_60

Avatar / Picture

Senior Member
Registered:
Posts: 796
Reply with quote  #7 
Quote:
Originally Posted by eliviardo
Thanks, yes, I've tried every adapter/cable i have every one of them works on my phone and other devices, the thing is that i can still use the device smoothly with no issues and can still connect it to escribe, and i've already asked thinkvape and evolv about this issue, but they still haven't replied yet. 


You may want to try this...in Escribe, go to Device Monitor>Diagnostics>Reset USB Current Limit...if the USB has been disabled, this will re-enable it...can't hurt to try...[biggrin]
eliviardo

Junior Member
Registered:
Posts: 6
Reply with quote  #8 
Thanks for all your replies, unfortunately i've already tried those possible fixes but still didn't fix my problem.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.