Evolv DNA Forum
Register Calendar Latest Topics
 
 
 


New Topic
Subject Author Views Replies    Last Post
Common Problems
1 2 3 4
blueridgedog 26,110 45
by giz_60
FAQ and Files (Report a Bug) Bapgood 1,091 0
by Bapgood
Therion dna 166 wont turn on or charge picklefinger 110 2
by BeardedWenger
Tugboat dna 250 wont charge v3ll3ry 70 1
by ChunkyButt200
no pics of "DNA Custom" mods XenonRam 90 1
by aonoukraine
DNA 250 Warranty Service when Atomizer connected Philippohappyhippo 57 1
by giz_60
No LiIon option in Escribe ttatlanta 156 13
by ttatlanta
DNA 250 Restarting Constantly Mourakue 90 10
by ChunkyButt200
DNA 200 need help Sytemrockr559 76 4
by ChunkyButt200
My triade 250 self fired and caught on fire jimmy912 174 9
by black lace
TRIADE DNA250 TC not always working. Madkat 67 7
by giz_60
Completely Dead Screen cesnimda 100 2
by cesnimda
Problem With Hcigar VT167 aslibanget 131 3
by giz_60
hcigar VT133 voltage issue
1 2
benpui 50 17
by giz_60
Not getting a new coil promt when I switch tanks. brianvape 708 12
by giz_60
Therion 133 (DNA 200) Neloy 133 6
by giz_60
DNA250 suddenly won't charge eliviardo 111 7
by eliviardo
Temperature Control not working at all.
1 2
millersd95 6,444 24
by Yggdrasil
Therion 166 (DNA 250)
1 2 3
etz1204 172 36
by Wayneo
Won't connect to Escribe Cyrus downing 53 3
by giz_60
Weird screen disconnects jumping up Jonnyw2k 63 7
by Wayneo
Control temp issue JABBER 75 3
by JABBER
LavaBox DNA 200 Issue biggest 58 2
by Wigz
[HELP] My finder 133 cant stop firing ari 309 7
by ari
only 0.1A Charging possible hs107 124 8
by hs107
Vapecige vtbox250 shorted message Pekkio82 178 7
by Pekkio82
Finder 167 dim screen themaka 104 1
by ultracom
Flicker Screen, Mess and Dead screen... On my HCIGAR VT167, anyone can help, please i beg you.... ardi 129 3
by Wayneo
Dna 200 wont wake up Wigz 105 2
by Wigz
check battery problem joker1975 158 1
by ChunkyButt200
Error press up to continue
1 2 3
mechaet 2,922 40
by Majiksmoke
Finder167 Fire button not working chai911 117 12
by chai911
Board Temperature stuck at 212F NKessler 76 3
by ChunkyButt200
Mad modder dna 250 screen problem morphflow 262 10
by morphflow
Hana V200 pre production resistance issues tattoo6.0 99 10
by tattoo6.0
Screen characters overlapping!! IMPORTKILLR 113 1
by black lace
Fuse Popping Tracking
1 2 3
DogMods 1,864 33
by NayBray
Hotcig DX200 autofiring Pickle187 93 4
by vapedudde
Screen not working correctly. Mod still working fine?
1 2 3 4
plcockrell 9,914 56
by Softarno
Hcigar VT200 is draining my battery while idle JimzDogz 984 12
by ChunkyButt200
sp 5 Bugs txmonkey214 175 5
by txmonkey214
(2) DNA250 boards not connecting to escribe vapinbig 162 8
by James
DNA 250 keeps powering down Ethrem 293 1
by Wayneo
DNA 200 tuglyfe help Myrddraal1 67 1
by ChunkyButt200
Temp Mode SP3 Doyle4 213 10
by telemachos
Weird cell voltages, board not working capchaos 286 11
by ChunkyButt200
Hotcig DX200 (and DIY) Fast Ramp up 200 W+? bilboda 74 4
by bilboda
The source and the nominal resistance is not equal? Mgeli 59 1
by Spirometry
Cannot Run Triade upilgoreng 96 0
by upilgoreng
Faulty DNA250? Doyle4 504 8
by Doyle4
 
New Topic

Quick Navigation: